Confluence Apps are not working as intended
Incident Report for AppFox Cloud Status
Resolved
There was an issue with the Atlassian JavaScript API which affected all of our Confluence Cloud applications.

Atlassian have released a fix and this problem is now resolved.

We apologize for any inconvenience this may have caused and we will continue to monitor the situation to ensure our applications continue to work as intended.
Posted Apr 01, 2021 - 07:59 UTC
Monitoring
The patch for Workflows for Confluence has been deployed and the App functionality should be restored.

We will continue to monitor the situation and respond to any after effects.

We'll update this incident when we have more information, along with the result of our communication with Atlassian on the cause of the issue.

We apologize for the impact this has had on our customers.
Posted Mar 31, 2021 - 18:58 UTC
Update
We have pushed a patch for the Compliance for Confluence App and it's functionality should now be available as normal.
Posted Mar 31, 2021 - 18:00 UTC
Identified
We have pushed a patch for the Approvals for Confluence App and it's functionality should now be available as normal.
Posted Mar 31, 2021 - 17:30 UTC
Update
Adding the Compliance for Confluence App to impacted services.

In this App, if a Confluence Page does not already have a Classification Level, the level will not be possible to set due to the same issue impacting our other Confluence Apps.
Posted Mar 31, 2021 - 16:30 UTC
Update
Update: Merging the Approvals and Workflows Incidents into a single one to track this issue.
Posted Mar 31, 2021 - 15:00 UTC
Update
We are continuing to investigate this issue.

If you have trouble loading certain pages or performing particular actions in either App, please check if you have the following symptom of the problem by opening your browser developer tools (F12) and note if the following error is being written to the browser logs:

Uncaught DOMException: Failed to execute 'postMessage' on 'Window': Symbol() could not be cloned.
Posted Mar 31, 2021 - 14:00 UTC
Investigating
We are investigating an issue effecting the Workflows and Approvals for Confluence Apps.

The Apps are failing when they try to communicate with the Atlassian Confluence API using the provided resources, which causes an unhandled exception which prevents the App from working - the easiest way to reproduce the problem is when trying to open the Page Byline panels of either App which appear on the top of each Confluence page where the App has been enabled.

A ticket has been raised with Atlassian to expedite a fix for this issue.

We are looking to prevent the issue from causing the App to fail by implementing additional request validation.
Posted Mar 31, 2021 - 12:00 UTC
This incident affected: Workflows for Confluence (Core App), Compliance for Confluence (Core App), and Approvals for Confluence (Core App).