Pulse for Jira Free - Resolution
Incident Report for AppFox Cloud Status
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 21:24 UTC
Identified
A resolution to the issue that occurred earlier today has been implemented and the fix is being deployed.
Posted Nov 18, 2020 - 20:11 UTC