Confluence webhooks outage causing app issues

Incident Report for AppFox

Resolved

Our Confluence apps have been confirmed as receiving and processing Confluence webhooks again.

Atlassian have informed us that they will not be able to replay any of the missing Confluence events from during the incident. We will discuss and action any possible mitigation steps to reduce the impact on users.
Posted Oct 23, 2025 - 08:25 UTC

Monitoring

Atlassian have implemented a fix, and we are now monitoring its effectiveness.
Posted Oct 22, 2025 - 22:18 UTC

Investigating

Our Approvals, Workflows, and Compliance apps are currently experiencing issues due to an incident (https://developer.status.atlassian.com/incidents/41ggtwj1f9f0) with Atlassian where Confluence webhooks are not being sent. As such, our apps cannot detect and appropriately respond to events that are occurring in Confluence. We believe this has been ongoing since roughly 02:15 UTC on 22 October 2025.

Affected Compliance features:
- Sensitive Data Detection is not being triggered on pages, so Automation rules will not be getting triggered either
- Default classifications are not being applied to pages
- AI classification is not working

Affected Workflows features:
- Default workflows not being assigned to pages
- Auto-assign rules not assigning workflows to pages
- On Edit workflow behaviours not getting triggered
- Moved pages may not have their Workflow correctly moved across with the page
- Workflows user not being added to pages where the content permissions are being updated
- Clean up actions not being triggered, so workflows from removed pages might be showing in the search
- Page restoring/unarchiving will result in the pages not having their Workflow correctly returned

Affected Approvals features:
- Expire on Edit for Page Approvals and Section Approvals won't be getting triggered
- Section Approvals won't be getting created on new and existing pages when done from templates or copy-paste
- Page restoring/unarchiving will result in the page not having their Section Approval correctly applied
Posted Oct 22, 2025 - 13:39 UTC
This incident affected: Approvals for Confluence (Core App), Compliance for Confluence (Core App), and Workflows for Confluence (Core App).