Disruption to service of Optro Cloud account management
Incident Report for AppFox
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 13:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2024 - 13:49 UTC
Investigating
We are currently investigating this issue.
Posted Jul 15, 2024 - 11:33 UTC
This incident affected: Trello Power-Ups (Approvals for Trello, Matrix for Trello, View Tracker for Trello).